Process 1

0. Prerequisite

Git install

  • Pure SLC5 has not repo for git. You need to install EPEL repo.
  • Make the file about epel repo on /etc/yum.repos.d/epel.repo.
[extras]
name=epel
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=$basearch
protect=0
  • Then,
yum install git

Quilt

wget http://download.savannah.gnu.org/releases/quilt/quilt-0.61.tar.gz
tar -zxvf quilt-0.61.tar.gz
cd quilt-0.61
./configure
make 
make install
  • Then, you can find quilt on "/usr/local/bin/quilt"

Kernel header.

yum install kernel-headers

1. Cloning lustre git

git clone git://git.lustre.org/prime/lustre.git

2. Runing autogen.sh

cd lustre
sh autogen.sh

3. Applying patches

cp lustre
sh autogen.sh
cp lustre/kernel_patches/kernel_configs/kernel-2.6.18-2.6-rhel5-x86_64-smp.config /usr/src/kernels/2.6.18-371.3.1.el5-x86_64/.config

Reference

-- GunmoRyu - 19 Dec 2013

Edit | Attach | Watch | Print version | History: r1 | Backlinks | Raw View | WYSIWYG | More topic actions
Topic revision: r1 - 2013-12-19 - GunmoRyu
 
KOREA-CMS
This site is powered by the TWiki collaboration platform Powered by Perl This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding KoreaCmsWiki? Send feedback